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i OVERVIEW

* This module is basically where we do the ‘nitty-gritty
part of the GIS training to come-up with final outputs

* You will learn how to obtain, create, manipulate, edit
geospatial data by series of tools and commands

* The exercises will be done step by step, along with
actual demonstration

* The exercises will make you “connect” the
theoretical part of GIS to its actual applications



. Because this module Is a
step-by-step process...

You need to do GIS!

i G — Ive attention to detalls
e | _tsas easyas ], 2,3

e S tay focused but relaxed



Data Acquisition

DATA SOURCES

Secondary Data
-existing maps

-digital maps (old maps,
scanned maps)

-topo maps

Primary Data

-GPS readings

-Google Earth captures
-surveys, traverse

KEY WORDS

Primary Data
Secondary Data




Data Capture, Preparation and
Processing

DATA CAPTURE PREPARATION AND PROCESSING

Importing
Coordinates/GPS
readings

Georeferencing a Capturing from

topo map Google Earth Geoprocessing

-points, lines, -clipping
I 1
polygon masking

-buffering

-GPS, Smartphones
-CSV Tables aml-pOINtS, lines, polygon

-intersect
This part is where data is exported to QGIS, -editing
edited, processed, projected into UTM, and {formatting
clipped, buffered, intersected to area of
interest



i EXER 1 GEOREFERENCING

WE WILL NOW TRANSFORM OUR SCANNED MAP TO A GIS
MAP BY PUTTING ITS ACTUAL LOCATION ON EARTH!

[E=Tfo8 )
22 - OBJECTIVE
KR e e To georeference a scanned map to be
used in digitizing

LANDSLIDE AND FLOOD SUSCEPTIBILITY MAP OF
PAETE QUADRANGLE,LAGUNA PROVINCE,PHILIPPINES

STEPS
1. Click Raster > Georeferencer
*it will open a new window

2. Click Open Raster and load the
image

8] coordnate: | 121, 1006, 14.5760 || scale || 1:2 ~ ][]/ Render |[psa:s2s5:1 [




/! Georeferencer - paete_unrectified.jpg

File Edit View Settings Help

B > [ % G

o8
0

B2 O L L L R M~ fioll

LANDSLIDE AND FLOOD SUSGEPTIBILITY MAFP OF
PAETE QUADRANGLE,LAGUNA PROVINCE PHILIPPINES

-
y’. Enter map coordinates

in coordinates of that point.

Enter X and Y coordinates (DMS (dd mm ss.ss), DD (dd.dd) or projected coordinates
(mmmm.mm)) which correspond with the selected point on the image. Alternatively, dick the
button with icon of a pencil and then dlick a corresponding point on map canvas of QGIS to fill

X /East: |

] Y /North:

Snap to background layers

2 Frmomp

Cancel

3. Click add points

File Edit View Settings Help
B > ({7 >:4> O L L P 4348

ad
e d

4. Zoom to the coordinates and
encode

5. Click Transformation settings



i BE CAUTIOUS!

WE NEED DECIMAL DEGREES FORMAT OF COORDINATES,
EXAMINE THE TOPO MAP

oordinates_conversion - Microsoft Excel non-commercial

Page Layout Farmulas Data Review View

Calibri -lu -l = g”@/j S Wrap Text General v ijgi ﬁﬁ _;dl E‘I 3‘ iil  Autosum = % i . .
B I U-||EA S A[E =||3= ==|| B8 Merge s Center - ||| $ - % » |[%8 ;9| | Conditional Format  Cell Insert Delete Format @ew- sort & F 6- Convert Coordlnates to DeC|ma|

Formatting - as Table ~ Styles - &2 Clear ~ Filter~ 5

- ‘ Font I} Alignment I} MNumber = Styles Cells Editing Deg reeS USi ng M S EXCeI
lame : Latitucde N : : Longi:ude E i Elev:tion I éoordinat:s : . . : (Coordlnate_conve rter)
! 2 ! ” (m) Morthing | Easting
T 7. Re-enter the coordinates to the add
ooen] oom points
oo o000 8. Start Georeferencing
when done
—1
2 . Sheet3 ¥ [ I
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-
' Transformation settings m

Transformation type: |Linear b
Resampling method: | Nearest neighbour hd D E FAU I—T VAI— U ES
Compression: MOME hd

Create world file

SAVING DIRECTORY

Qutput raster:
orget SR —— COORDINATE SYSTEM
Generate pdf map:
Generate pdf report:

Set Target Resolution
Horizontal | +.00000 =
Vertical | -1.00000 =

Use 0 for transparency when needed

®| Load in QGIS when dnne/

MARK THIS




NOTES AND TIPS

NOTE:
THERE CAN BE ERRORS FROM UPLOADING CONTROL
POINTS, MOSTLY TYPOGRAPHICAL

TIP:
TO CHECK FOR THE CONSISTENCY OF THE GEOREFERENCED
MAP, OPEN OTHER PROJECTED MAPS FOR COMPARISON




1 EXER 2 DIGITIZING

USING OUR NEWLY GEOREFERENCED MAFP, WE WILL NOW
EXTRACT FEATURES FROM IT!

/' QGIS 2.20-Valmiera E=RRe X

Project Edit View Layer Settings Plugins Veftgr Raster Qatabase‘Processing Help - : OBJ ECTIVE

DERBROLR @&@-K-G & BE=-0mno » 5 et | i . f
[Ho®rr 2 APORARR £/ B 62K~ o digitize polygons, lines, points from

(

the georeferenced topo map

v El- % /" pagsanjan_river_utm

'o El- % () pagsanjan_500m_utm

21 s STEPS
: = 1. Open georeferenced map
-]

£ : :
@ 2. Cick new shapefile layer % F°
- a” L
‘ 2 3. Select type
i

4. Zoom to area of interest

] coordinate: | 230936, 1614926 |[scate |[ 393,062 |+ |[7][%/ Render |[epsc:32651 |[@)]



Type

Point

EPSG:4326 - Spedfy CRS
Mew attribute
Marne

Type | Textdata -

width | 80 Predsion | |

[ Add to attributes list ]

Attributes list

Name Type I Width Precision
id Integer

(<] | [41+]

[ Remove attribute ]

CHOOSE LINE IF YOU WILL
DIGITIZE RIVERS

CHOOSE UTM_ZONE5SIN




er Database Processing Help

4. Click “Toggle Editing’

i’" J \@. \vaR
|Tn::u;|gle Editing i

5. Click ‘Add Features’

6. Trace

7. Save edits




#Note
Digitizing is basically tracing the features from
the base map
Tips:
Zoom as much as possible and stay focused,
use a better mouse and try adjusting mouse
cursor speed at the control panel

You can switch buttons to pan or zoom the

map, just click again the ‘add features’ to get
back from digitizing




EXER 3 CAPTURING FROM
GOOGLE EARTH

Now, we will go to the globe to capture features and put it to our

mabp laver!

2.0-Valmiera - exer:

Zdit View Llayer Setings Plugins

Vector Raster Datsbase

Processing  Help

] Q @ ‘\/:; '5 'D Jf’u R ) q-jﬂ Save vector layer as...

.
e

™
I

AL ARPDD&SR
i %:—Igh,

M (% M6 I 3

L| = Zoom to Layer Extent
Show in Overview

J Remove
[ Duplcate
SetLayer CRS

Set Project CRS from Layer
Open Attrbute Table
/' Toagle Editing

Save Selection As...
Filter.
Show Feature Count
Properties
Rename
Copy Style
Add New Group
] Expand Al
"l Collapse Al
X Update Drawing Order

editing state of the current layer

= |
[

o
b

o

Format Keyhale Markup Language [KML] -
Save as
C:/SESAM_TRAIMING _OTHERFILES fwatershed_calumpang.kml Browse ]
Encoding [UTF-S | v]
CRS Layer CRS -
WGES 84 /UTM zone 51N Browse
Symbology export Mo symbology -
Scale 1:50000 =
Skip attribute creation I
Add saved file to map |
[ More Options > ]
|
OK | Cancel Help

[5][cooranet=:|

Y

|[scate [ 177,824

272722,1541392

~[57][% render ||ersc:

OBJECTIVE
To obtain spatial features from
Google Earth and import it to

QGIS
STEPS

1. Save our area of interest
as .kml

Resulting icon will be like this

S

fishpens

2. Open it to Google Earth



CHOOSE KEYHOLE MARKUP

LANGUAGE (.KML/GOOGLE

EARTH FILE EXTENSION

Format ESRI Shapefile /

Save as

Encoding LITF-8

CRS Layer CRS

['-."'."GS 84 /UTM zone 51N

Browse

Symbology export Mo symbology

Scale 1: 50000

Skip attribute creation

Add saved file to map

Mare Options ==

Cancel

Help




3. Navigate and zoom to
area of interest

P [ The latitude in degrees of the focus point

] Ali;hjdﬂ
)

4. Add features

A+ +| g+
i |__I a_b

5. Save and open to
QGIS

PRED 6. Save the kml as .shp
ES el il : by clicking ‘save as’
after right clicking
the kml




#Note
Captures from Google Earth are not yet
projected into UTM
Tips:
Make it a practice to check and project every
hew entry




i EXER 4a Clipping a Raster

Now that we have features, we will add more map layers to our project! Let’s
how clip some features from the surface! This timeit's a raster

0-Valmiera

t View Layer Settings Plugins Vector |Raster \_!gAa}‘fa_bagg rocessint

s = L2 Rastel E o &
BERLR & &+= I Be-05o -
] :éi» JK*'-‘ ?‘T} «/{‘151" ;: )/‘ i 'I_L:::’:;:non 4 : ’ ‘ oo & BoS

e e— [ A | To clip a DEM raster to the
' ' scale of interest

Projections

STEPS
1. Add DEM file

2. Click ‘Raster’,
Extraction, Clipper

[$[ coordinate: | 120.539. 14,754 ['scate I'1:519.27:



SOURCE OF RASTER FILE

Input file (raster)  was_utm - Select...

Output file | C:/Hip_DEM Select...

Mo data value [D

Clipping mode

Extent ® Mask layer

CLIPPING EXTENT (AREA OF INTEREST)

Mask layer watershed revised @~

Create an output alpha band

X Load into canvas when finished

&N

gdalwarp -g -cutline C:\CALUMPANGATION yWwatershed_revised.shp -
crop_to_cutline -of GTiff "C: Mew folderjwgs_utm™ C:jdip_ DEM



¢ EXER 4b Clipping a Vector

WE WILL BASICALLY DO THE SAME CLIPPING, THIS TIME IT
IS AVECTOR FILE!

& QGIS 2.2.0-Valmiera

Project Edit Wiew Layer Settings Plugins

N & R e E;:;::ECW& :o e R o - W B OBJECT'VE
AOBBL LT e ) B RB To clip land cover map to area of

Road graph

El-[% 9 subbasin srtm wtm Spatial Query 1 t t
Table Manager I n e res
=] (= 2010_lida_boundary Topology Checker
| ﬁ Analysis Tools 4
=% = 2010_land_cover_subbasi 1

2.2 Research Tools

STEPS

O Geoprocessing Tools @ Convex hull(s)
& Geometry Tools Y Buffer(s)
a Data Management Tools  * | o e 1 Add Ve Ctor fi IeS

2. Click Vector >
Geoprocessing tools > Clip

3. Fill-in the clip window

ml Coordinate: ” 285131,1624611



7 or M~ ==

Input vector layer

20 nd cover e etent m
Use only selected features \

Clip layer
subbasin_srtm_utm \ EA OF INTEREST
;ﬁ Use only selected features >
Cutput shapefile
Browse
% Addresult to canvas 0 >
(] 0% || ok Close




Project Edit View Layer Settings Plugins Vector Raster Database Processing Help

NEERBOR @6 N - s BEe-0 50 »

PR

OB PP AP

GIES

£ % [~ sancristobal_lcover2010_clipped

= 3 # subbasin srtm utm

@, |2 2010 1da_boundary

,. El . (5 2010_land_cover_subbasin_extent
+

A/ BRRRG>xE

Toggles the editing state of the current layer

Coonhahi”.l

269841,1634533

||scale || 1:614,772 [vlﬂ@]fii Rend




#Note:
There are various raster
processing from DEM including
slope, elevation, contour, and so on

Tips:
Explore the ‘terrain analysis and
other raster commands




1 EXER 5 INTERSECTING

We will continue to add map layers to our scale of interest!

/! QGIS 2.2.0-Valmiera

This time, we will overlay two features

Project
0

)

a,

DINRNS

Edit View Layer Settings Plugins

BELR &

Coordinate Capture
Dxf2Shp

@ ;:» [@ }9 '.11 ;} ; SPpZnSVeetMaD
Layers

E- % [~ lcover2010_lida_utm

Road graph
Spatial Query
Table Manager
Topology Checker
4 Analysis Tools

3% Research Tools

[0 comrocmmry o+ L m—m—E

" Geometry Tools

= Dsta ManagementTools  »

Vector | Raster Database Processing Help
» 5

= oo -
, Bl mm Y -
3 ! = =
LA N
»

>
L2 # Buffer(s)

‘ Union

£ Symetrical difference

a3,

8 =

15

W
i

@

-

OBJECTIVE
To overlay sub basins and land
cover 2010

STEPS

1. Add vector files
-subbasin_srtm_utm
-landcover2010 llda utm

2. Click vector > geoprocessing
tools > intersect

@‘ Coordinate: H

233243,1601839

|[scale |[1:614,772 |~ |[S7][%] Render |[epsc:32651 (@)




= 2. Fill-in the intersect
window

3. Save

1

Input vector layer
lcover2010_llda_utm -

LAYER 1 (AREA OF INTEREST)

Use only selected features
Intersect layer
subbasin_srtm_utm

LAYER 2 (USUALLYLARGER SCOPE)

Use only selected features

Qutput shapefile

Browse OUTPUT FILE DIRECTORY
X/ Add result to canvas
[I 0% ] | OK Close




i EXER 6 BUFFERING

Buffering is creating easements from a line (i.e river) and perimeter. It is
important in defining buffer zones for policy implementation and planning

Now, we will generate buffer zone from our main rivers!

almi
ew laer Setngs Puors [Vedr| Raster Dowbese Proseg B OBJECTIVE
Coordinate Capture [ - 50 — ek o
BERLR @ 7. EE &0 g : To create buffer of varying
:":" d’ 0’_> e .;} EPS StreetM : y J B <R A 5 S
= =i o 4 OpenStreetMap ., A ks Al &3 1
— . distances
' () pagsanjan_river utm Spatial Query i
-' " Table Manager 4
Topology Checker »
4 Analysis Tools 4 STE PS
“. Research Tools 4

D o 1. Open river of interest
S 2. Click Vector >

£ Symetrical difference

v cin Geoprocessing tool >

B, Difference

' Dissolve B uﬁe r

9 Eliminate sliver polygons

@\ Coordinate: | 326152,1587474 [[scate ][




= 3. Fill the buffer window

e

W Buffer(s) ;

Input vector layer . .
pagsanjan_river_utm - \ River (Or any) line or polygon

se only selected features

4k

Segments to approximate 5
® Buffer distance 500 \ Buffer distance in meters

Buffer distance field

id -

Dissolve buffer results

N
Qutput shapefile
Browse \ Directory of output file

@Esulttu mn'u'aD
T |




7 QE1S 220 Vaiviers T

Project Edit View Layer Settings Plugins Vector Raster Database Processing Help

DEEERR aa-flaesBE=-0 5 -

VOPLLPHPLRALAR 4/ BRR & %>
' Layes &)X

2o

B- % 2 njan_river_utm

- % () pagsanjan_buffer500m_utm

(V'S |r‘-\rdin=+¢- ” 277272 1coTNNn ”_c



STEPS

4. Repeat this procedure for other buffer distance

s 120vine IR

Project Edit View Layer Settings Plugins Vector

DEBEBRBOR

HOSPLAPRPLRAL

Ex

W e

Raster Database Processing Help

& G -50- g & TR RN

(= |
e/

| I

E- % / pagsanjan_river_utm

£ % (- pagsanjan_500m_utm

'(} o .. paete_rectified
- % (- subbasin_srtm_utm
AR

= lcover2010_lida_utm

BRSO 00N0AY

L ANDALIZE ARD FLOOS BUSCEFTIE UITY MAF OF
CPRETE CURONARKGE SN P AGYINLE, "FLiee MES

|VCoordinabe: ”

290936,1614926

|[scale || 1:399,062 |+ [§7][%¢ Render J]EPSG:32651| L



. EXER 7 EDITING THE
ATTRIBUTE TABLE

OBJECTIVE
To add data on lake and compute

Project Edit View Layer Settings Plugins \Vector Raster Datsbase Processing Help

NEBRLR Ge MleeBEs-0 5 - density of fish pens/cages
AVBPLPRPPLLLR AJ/)BRBR/& w<b

Layess [&)X]
% / lakezoning utm

STEPS
1. Insert zoning map of LL

2. Open attribute table, toggle
editing

NS DI SNS

ribute table - lakezoning_utm :: Features total: 6, filtered: 6, select... L (]

JOp & EEEEERE [ E)E

> MUN20 © | NamE2 PROVINCE _ FID_2010F e’ 1
| o = =
[ i A —
4] | c—c T —— :
L — 3. Add columns on number of fish
[ e — GT)
(o) pens, cages, ponds (if
necessary)
2 object(s) removed. [5] coordinate: | 292953, 1571587 |[scale | 1:259,675 |~ |[S7][% Rend

4. Compute for its density



H 4. Add column (encode data on fisheries) [ 5. Save edits
LT

( V' Add column @g
seme | popuaiion Added field/column
Comment \
Type Whole number (integer) | ™
What to enter (whole number,
with decimal, text)
integer

width  [E —

Length of character

| QK Cancel




4 reacroitor gy, S A |

Only update selected features

ADDING COLUMN FOR AREA

®| Create a new field
Output field name | Area_ha

Output field type | Dedmal number (real) | = [OBJECFID |v]
Output field width | 10 | 5| Precsion [0 |5

Update existing field

Function list Selected function help
Search Sarea funetion
-.-.-E:Lc;etry B Returns the area size of the curreg featuses=— COMPUTING FOR AREA
;:f[ D SNvIltax
- Sarea Zarea
z:::rig:nheter Arguments L]
- S Hone i
- Sgeometry E Example z
W Operators
= £ = { * - Il { J
Expression = COMPUTING FOR HECTARES
Zarea f10000 =

(default area is in sg.m)

Output preview: 55 537900503174




#Note
Computed areas for a political entity (i.e.
barangay, municipality, city, province) can vary
from its official area

Tip:
Use the GIS computed area of political
jurisdiction for computation purposes only to
avoid inconsistencies of attributes




i EXER 8 RASTER OPERATIONS

Project Edit View Layer Settngs Plugins Vector |Raster | Database Processing Help

D @F?Wﬁﬂ

Input file (raster)
Output file for contour lines (vector)
Interval between contour lines

Attribute name

%= Raster calaator ..

Georererencer
Heatmap
Interpolation

@ (@ Terrain analysis »

Zonal statistics
Projections
Conversion

4 = -

Analysis L ‘ 8 Clipper
»

¥ Contour Miscellaneous ? 3
| GdalTools settings

srtm_S0m

b Select...

stsfcontour_10.shp | | Select...

10.000

|ELEV
If not provided, no elevation attribute is attached.

% Load into canvas when finished

gdal_contour - 10.0 C:

\Users\acer \Desktop\GISTraining_Datasets_Day2\Exer7_RasterOperations\srtm_g0m. tif

C:/GISTraining_Datasets/contour_10.shp

o]

Close

P
v

Help

Builds vector contour | —- -~ -~

e |[us:

OBJECTIVE
To perform common raster

operations from DEM

STEPS

1.

Insert srtm_90m

Create contours by clicking
Raster > Extraction > Contour

Define contour interval and save



: l/- QGIS Z.Z.O-Valmierav*_wl =0 &lﬂ
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Project Edit View Layer Settings Plugins Vector Raster Database Processing Help

PEROR 6 M -GeBEa-0 50 »
A LLPAPPLRAKR 4 /BLRRG>xE E
Layers

&)

Va
'0 x :|' marikina_clipped_90m1
Bl | 9 elevation_marikina
? =N
E- % [ subbasin_srtm_utm
| N
&
7%
%%
\/‘5 v
266334.45,1591275.08 : 344256.24,1650191.55 |Coordinahe: | 266651,1623584 |[scale |[ 399,062 |~ |[67][3! Render |[epscizasst |




i EXER 8 RASTER OPERATIONS

OBJECTIVE
To perform common raster

e . _a o T o
Project Edit View Layer Settings Plugins Vector |Raster | Datsbase Processing Help Oper atlo nS frol I I D E M
=
=Hcinic, o % Rester caalator .. ool s
0 d R (& st + | S

Howppsnapy m

Interpolation

7 QGIS 22.0-Valmiera

Layes 8| @ Terrain ana lyss b
Vo Zonalstatstics

3. Convert into vector (polygon) by
clicking Raster > Conversion >
Polygonize

¥, Translate (Convert format)
y A Miscellaneous R

" PCT toRGB

Produces a polygon featire layer from a raster [%5])| coordinate: | 120,856, 14,851 [scale [[ 1519272 |~ |[&7][¢ 1




I THANKS FOR YOUR TII\/IE}



